Page History
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Problem
Changes on Zendesk tickets get not picked up by the Exalate, no synchronisation is happening
Root cause
Exalate for Zendesk is a 'push' type of integration, where a webhook on the Zendesk side will notify the exalate that a ticket is created or updated.
If for some reason that webhook gets deleted - Exalate will never be notified about the fact that an update or create happened
Remedy
Step 1 - Recover the Exalate url
Make sure that you got the address of your Exalate for Zendesk.
It is an URL with following format https://zendesk-aaaa-bbbb-cccc-dddd.exalate.cloud
This can be found in the general settings of the Exalate app
Step 2 - Add a target
The target will be used to define where a webhook needs to be sent.
Target can be found at Zendesk Admin → Extensions
Add a target, select HTTP target
Enter following fields
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Step 3 - Configure the webhook
Access 'Triggers' in the admin section, and 'Add trigger'
Configure the name and conditions in the section 'Meet ANY' of the following conditions
Configure the action
Set it to 'Notify Target' and select the target just created
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Snippet |
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{ "ticket": { "id": "{{ticket.id}}", "subject": "{{ticket.title}}" }, "executor": "{{current_user.email}}" } |
Step 4 - test it
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